Search found 69 matches

by M*I*B
2020-08-27 17:53
Forum: General discussions
Topic: ExceptionHandler::Run, Description: An error occured while executing 'Task-DeliveryTask'
Replies: 4
Views: 217

Re: ExceptionHandler::Run, Description: An error occured while executing 'Task-DeliveryTask'

VR's on a VR doesn't work, hu? ;o)

That will not work. Maybe an rootserver, but that's many to much for us... So we drive an external VPS ...
by M*I*B
2020-08-27 15:20
Forum: General discussions
Topic: ExceptionHandler::Run, Description: An error occured while executing 'Task-DeliveryTask'
Replies: 4
Views: 217

Re: ExceptionHandler::Run, Description: An error occured while executing 'Task-DeliveryTask'

.. i think HMS isn't able to handle the config I have to drive. HMS can't be MX and Relay for an 2nd HMS at the same time . So is there a way to install two independent HMS instances on the same machine? It's enough to use different folder and change the servicename by hand before installing the 2nd...
by M*I*B
2020-08-27 14:13
Forum: General discussions
Topic: ExceptionHandler::Run, Description: An error occured while executing 'Task-DeliveryTask'
Replies: 4
Views: 217

ExceptionHandler::Run, Description: An error occured while executing 'Task-DeliveryTask'

... never ending story :cry: "ERROR" 1916 "2020-08-27 14:07:55.071" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk." "ERROR" 1916 "2020-08-27 14:07:55.071" "Severity: 2 (High), Code: HM4208, Source: ExceptionHandler::R...
by M*I*B
2020-08-26 12:47
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

.. don't help ...

Have copy the ca behind the cert- section and use this file. No errors while starting the HMS but again... no in, no out, no touch from mxtools... That's crasy
by M*I*B
2020-08-26 12:37
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

.. hatte ├╝berlesen das Du auch Deutscher bist ...
by M*I*B
2020-08-26 12:33
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

.. if I do that the way you tell me with the ca_bundle I got an error while restart the HMS: Error: use_private_key_file: key values mismatch The CA is the one I got from SSLforFREE together with the certificate file. So it MUST match the key... Or is some wrong the way I create the key-file with op...
by M*I*B
2020-08-26 12:18
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

.. the key file I have create brand new ... Now I have do this: openssl genrsa -out kie-hb.key 2048 <- this one: 26.08.2020 11:31 openssl req -new -key kie-hb.key -out kie-hb.csr -then I go to ssl4free -give the csr to it and got two files back: ca_bundle.csr and certificate.csr I have set in HMS th...
by M*I*B
2020-08-26 12:07
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

... hu ???? Have you read my answer just right before yours?
by M*I*B
2020-08-26 11:49
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

... to edit the file can be done by a batch every time it see that it is renewed. That's at end what I like to have. The LetsEncrypt tut I have try a longer time before but can't get it running.. Or maybe you talk about an other tut? Now I have do this: openssl genrsa -out kie-hb.key 2048 openssl re...
by M*I*B
2020-08-26 11:08
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

BTW: I'm wrong... That with the CERT don't work! "ERROR" 7540 "2020-08-26 11:04:50.686" "Severity: 2 (High), Code: HM5113, Source: SslContextInitializer::InitServer, Description: Failed to load private key file. Path: C:\Program Files\Abyss\kcstore\5f0a29d3.key, Address: 0.0.0.0, Port: 25, Error: us...
by M*I*B
2020-08-26 10:49
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

On Serverside there is the MS Defender (with excluding hms folders) and ClamAV for HMS itself. Local we use G-Data.
From both (on server and from here) the error is the same
by M*I*B
2020-08-26 09:31
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

... well done ... Looks like that is the point. I can send and receive with the files right now without an error. Also MXtools say that's all well right now. Tank you very much for that! Maybe a good idea for the ToDo to tell HMS to ignore all outside -----BEGIN CERTIFICATE----- and -----END CERTIFI...
by M*I*B
2020-08-26 08:08
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

... Ok, I will test that out and let you know about the result ...
by M*I*B
2020-08-25 12:08
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

... I haven't take a look into the log due if I use it unconvertet nobody can connect to the server. In the live log errors comes up like cert error, type mismatch, SSL-error... My CRT createt by ABYSS via LetsEncrypt looks like this: ACMECERT1 https://acme-v02.api.letsencrypt.org/directory (here ar...
by M*I*B
2020-08-25 10:48
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

.. shure .. then all goes wrong.
It must be convertet to PEM, but that include also the private.key where I don't know how to convert ...
by M*I*B
2020-08-25 07:52
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Re: Again SSL-Cert

... can be .. I can't say that due I use a windows server ... And I just have two files to work with: private.key and certificate.crt And this is the base of my question. I know that some do it this way but I can't find an HowTo about it... Can't not be heavy to convert this files that HMS can use i...
by M*I*B
2020-08-24 11:52
Forum: General discussions
Topic: Again SSL-Cert
Replies: 24
Views: 632

Again SSL-Cert

Sorry for that, but there are some things I don't understand... I use the ABYYS web server because it can automatically generate LetsEncypt certificates for the domains. Now I got the idea to use these certificates for the HMS as well. To do this, I monitor the directory in which ABYSS stores the ge...
by M*I*B
2020-08-24 11:42
Forum: General discussions
Topic: ERR: ... since rule loop count was reached or Auto-Submitted header."
Replies: 6
Views: 265

Re: ERR: ... since rule loop count was reached or Auto-Submitted header."

... maybe we talk on different base ... The AutoResponse is set on the HMS itself as information for the sender. That works well... except the autoresponse comes back due not existing sender (fake- adress / Spammer). The way is: Sender -> HMS-Domain#1 -> Forward to Domain#2 | Fake <- AutoResponse <-...
by M*I*B
2020-08-21 12:17
Forum: General discussions
Topic: ERR: ... since rule loop count was reached or Auto-Submitted header."
Replies: 6
Views: 265

Re: ERR: ... since rule loop count was reached or Auto-Submitted header."

... I'm just not noticed what Auto-Submitted header realy means ... If that like this then I can't follow up why that comming up... The HMS#1 works as MX for domain#1 and also as relay for the local HMS#2 with domain#2 behind a firewall. The HMS#1 do handle the old domain#1. There is set a autorespo...
by M*I*B
2020-08-21 07:58
Forum: General discussions
Topic: ERR: ... since rule loop count was reached or Auto-Submitted header."
Replies: 6
Views: 265

ERR: ... since rule loop count was reached or Auto-Submitted header."

Hello there, got some similar new errors in the log like this: "ERROR" 4428 "2020-08-21 07:34:51.152" "Severity: 3 (Medium), Code: HM4404, Source: SMTPDeliverer::_ApplyForwarding, Description: Did not submit bounce message for message 1719 from [user]@[domain] since rule loop count was reached or Au...
by M*I*B
2020-07-13 13:30
Forum: General discussions
Topic: Again: rDNS and HELO
Replies: 3
Views: 461

Re: Again: rDNS and HELO

... ty for the open words; I have today two target with "Remote server replied: 550 Access denied - Invalid HELO name (See RFC5321 4.1.1.1)". But the HELO and all other are the same. I also have last week some targets bounce it back due wrong rDNS... So I can not confirm your statement regarding rDN...
by M*I*B
2020-07-13 11:45
Forum: General discussions
Topic: Again: rDNS and HELO
Replies: 3
Views: 461

Again: rDNS and HELO

Hello all, after moving an other hMail to a new server (with an other IP) again get trouble with that stuff due MXtools tell me "Reverse DNS is not a valid Hostname" (I hate to read that... realy!) Ok, what I have do: DNS : MX point to FQDN.de (and not to mail.FQDN.de) rDNS : Servers IP point to FQD...
by M*I*B
2020-07-08 20:23
Forum: User contributed hMailServer 5 scripts
Topic: Automatic whitelisting
Replies: 172
Views: 133535

Re: Automatic whitelisting

... that I can do, that I can do! Yappyapp :lol: EventHandlers.vbs, Line 152 to 161 If upd = True Then write_log (" execute update") if fs.FileExists(vbs_update_wl) then WshShell.run(vbs_update_wl) else write_log (" Error, cannot find: " & vbs_update_wl) end if End If End Sub EventHandlers_awl_updat...
by M*I*B
2020-07-08 16:36
Forum: User contributed hMailServer 5 scripts
Topic: Automatic whitelisting
Replies: 172
Views: 133535

Re: Automatic whitelisting

Just a short: "ERROR" 4696 "2020-07-08 15:43:20.447" "Script Error: Source: (null) - Error: 80070002 - Description: (null) - Line: 155 Column: 3 - Code: (null)" That comes up in ERROR-log every time the script insert a new adress in ... So I'm not a coder and only can copy & past... Any idea what I ...
by M*I*B
2020-07-07 18:57
Forum: General discussions
Topic: Global rule don't work as expected
Replies: 7
Views: 595

Re: Global rule don't work as expected

.. ty a lot! I will try that...
by M*I*B
2020-07-07 15:50
Forum: General discussions
Topic: Global rule don't work as expected
Replies: 7
Views: 595

Re: Global rule don't work as expected

Ok, now it work's well since I have understand that I have set the x-hmailserver-loopcount by actions and check x-hmailserver-loopcount by Criteria.. SOmetimes I need more time from eyes to brain :lol: Now I have a 2nd Q about this: Now I set: IF x-hmailserver-loopcount LESS THAN 1 AND X-Spam-Level ...
by M*I*B
2020-06-30 09:39
Forum: General discussions
Topic: Global rule don't work as expected
Replies: 7
Views: 595

Re: Global rule don't work as expected

AHHHH! :lol: :lol: :lol: :lol:
Ok, That makes sense :roll: That's why I never seen this Header-line before...


Thanx a lot!
by M*I*B
2020-06-30 09:26
Forum: General discussions
Topic: Global rule don't work as expected
Replies: 7
Views: 595

Re: Global rule don't work as expected

... thanx for the fast answer!

I have delete the Colon right now...

What I can't handle/understand is the "x-hmailserver-loopcount"... I haven't this in any header.. Or I'm wrong looking for that in Spam- header?
by M*I*B
2020-06-30 09:14
Forum: General discussions
Topic: Global rule don't work as expected
Replies: 7
Views: 595

Global rule don't work as expected

Hello there, I know it's hard to get an answer here but I will try again with a new question: If I declare a global rule (/Rules) like ... "X-Spam-Level:" Contains "*" AND "To" Contains "[domain]" Forward email -> spammer@[domain].[tld] Delete e-mail ... it doesn't work. They don't notice the 1st co...
by M*I*B
2020-06-02 13:36
Forum: General discussions
Topic: Coupling of two server (Master/Slave): Best way?
Replies: 9
Views: 1449

Re: Coupling of two server (Master/Slave): Best way?

... sorry for late response; much to do and also some inside my family ... Friday, 19. Juny is the day of the truth :roll: I hope I have all well understand. The "problems" with Linux I don't have due the WAN and the LAN Servers are both WIN. There are so much points you can enter information to the...
by M*I*B
2020-05-10 11:57
Forum: General discussions
Topic: Coupling of two server (Master/Slave): Best way?
Replies: 9
Views: 1449

Re: Coupling of two server (Master/Slave): Best way?

... ok, I will repeat in my own words and then let's see if I have understand it right... On the external Server where also the Webside of the Company resist I install hMail without enter a domainname under "/Domains". Then I go to "/Settings/Protocols/SMTP/Routes/" and set a Route to the local hMai...
by M*I*B
2020-05-10 10:34
Forum: General discussions
Topic: Coupling of two server (Master/Slave): Best way?
Replies: 9
Views: 1449

Re: Coupling of two server (Master/Slave): Best way?

Ok, a question has not yet been answered; I don't understand one thing here: Question 1: If the WAN mail server serves as a pure relay and there are no domains or users entered, how does that work? How does the mail server know that it is responsible if an external mail arrives at User-A, but User-A...
by M*I*B
2020-05-08 11:08
Forum: General discussions
Topic: Coupling of two server (Master/Slave): Best way?
Replies: 9
Views: 1449

Re: Coupling of two server (Master/Slave): Best way?

:roll: you are right; haven't seen that :lol:
by M*I*B
2020-05-08 07:51
Forum: General discussions
Topic: Coupling of two server (Master/Slave): Best way?
Replies: 9
Views: 1449

Re: Coupling of two server (Master/Slave): Best way?

Good Morning ... ... and thank you for this presentation. First of all the advantages and necessities: We have a fairly high internal mail volume because the document management is based on it. Sending these documents outside and then back again makes no sense and also represents an unnecessary secu...
by M*I*B
2020-05-07 21:23
Forum: General discussions
Topic: Coupling of two server (Master/Slave): Best way?
Replies: 9
Views: 1449

Coupling of two server (Master/Slave): Best way?

Greetings all together ... ... how is the best way to couple two server as Master/Slave? I like to couple a Master, working as real MX like the most, and a 2nd one as Slave, working on a intranet. All communication have to go over the internal slave (inhous and the whole world) and this one give it ...
by M*I*B
2020-03-31 16:24
Forum: General discussions
Topic: t-online reject with "Remote server replied: 554 IP=5.44.107.42 - A problem occurred. ..."
Replies: 9
Views: 2137

Re: t-online reject with "Remote server replied: 554 IP=5.44.107.42 - A problem occurred. ..."

... yes, PTR is right. Don't know how often I double checked that and some other things.

Yes, maybe a good idea to go on there nerves to check that ...
by M*I*B
2020-03-31 15:15
Forum: General discussions
Topic: t-online reject with "Remote server replied: 554 IP=5.44.107.42 - A problem occurred. ..."
Replies: 9
Views: 2137

Re: t-online reject with "Remote server replied: 554 IP=5.44.107.42 - A problem occurred. ..."

just an info why (direct translated via google) For security reasons, our system does not accept emails in principle unknown hosts. This may also include hosts / IPs that use email for a long period of time (longer than at least one year) have delivered. This obviously applied to 5.44.107.42. Can no...
by M*I*B
2020-03-30 22:59
Forum: General discussions
Topic: t-online reject with "Remote server replied: 554 IP=5.44.107.42 - A problem occurred. ..."
Replies: 9
Views: 2137

Re: t-online reject with "Remote server replied: 554 IP=5.44.107.42 - A problem occurred. ..."

It would help if you could provide the full error message. No problem. I got back this (deleted emty lines, star out the receiver-name): Your message did not reach some or all of the intended recipients. Sent: Mon, 30 Mar 2020 17:34:25 +0200 Subject: Kc3bcndigung Mitgliedschaft Schc3bctzenverein Me...
by M*I*B
2020-03-30 18:15
Forum: General discussions
Topic: t-online reject with "Remote server replied: 554 IP=5.44.107.42 - A problem occurred. ..."
Replies: 9
Views: 2137

t-online reject with "Remote server replied: 554 IP=5.44.107.42 - A problem occurred. ..."

Hello there, since some days or weeks I have a problem sending out emails to t-online.de. I don't know how to fix that due I don't see any wrong... I use multiple domains. All point to the same IP. In DNS for every domain an MX- entry is set for the domain and also correct DKIM that say that all my ...
by M*I*B
2019-12-09 00:23
Forum: General discussions
Topic: Trouble Multidomain sending = wrong SSL-Cert
Replies: 8
Views: 1620

Re: Trouble Multidomain sending = wrong SSL-Cert

... ah ok .. Good to hear that x64 are on birth. Not for me due I'm not a Dev and also have no access to it. But if a BETA is out I'm glad to give it a try ...
by M*I*B
2019-12-08 18:15
Forum: General discussions
Topic: Trouble Multidomain sending = wrong SSL-Cert
Replies: 8
Views: 1620

Re: Trouble Multidomain sending = wrong SSL-Cert

... ok, ty a lot. Now I got it (I hope :lol: ) I was going the harder way and generate a global Cert for all domains as domain.tld and mail.domain.tld and use if for all kind of MX- things. That works well and due there is no wildcard I can use FTP-verification to renew it... (there are a few more t...
by M*I*B
2019-12-07 15:35
Forum: General discussions
Topic: Trouble Multidomain sending = wrong SSL-Cert
Replies: 8
Views: 1620

Re: Trouble Multidomain sending = wrong SSL-Cert

... maybe I'm to stupid to understand or maybe we talk about different things ... I talk about before sending out a message from my server to the receipents server. At 1st I have to write a message (in any fav. client like Thunderbird). If that ready I have to click "SEND". Then the client get in to...
by M*I*B
2019-12-07 12:32
Forum: General discussions
Topic: Trouble Multidomain sending = wrong SSL-Cert
Replies: 8
Views: 1620

Re: Trouble Multidomain sending = wrong SSL-Cert

... ahhhh, ehhhh, hmmm ... :roll: Ok, let's see if I understand it right... I.e. I take my 1st domain as Master with Cert. Then I go to my Nameserver- Settings and let point all other domain MX-records to that Master-domain-name? So how do prevent this way the problem that i.e I try to send from a m...
by M*I*B
2019-12-07 11:04
Forum: General discussions
Topic: Trouble Multidomain sending = wrong SSL-Cert
Replies: 8
Views: 1620

Trouble Multidomain sending = wrong SSL-Cert

Greetings from Germany... I'f got some trouble after changing all my stuff to a new Server/Provider with SSL I have 6 Master- Domains, some of them include other ones as Aliases (in TAB "Names"). Now after all is running well I just try to send out an eMail (Thunderbird -> hMail) via "mail.sv-meisse...
by M*I*B
2018-01-22 10:47
Forum: Scripting
Topic: If SPAM add IP to blacklist or IP-Ranges ?
Replies: 7
Views: 3639

If SPAM add IP to blacklist or IP-Ranges ?

Hello there from Germany... ... and at 1st excuse my ugly English pls :roll: I use hMail since some years without trouble. Since beginning using it I enter often a whole IP-range to the same named list and disallow all to prevent Spammers to touch the server. Ranges comes from Asia, Russia a.s.o. ar...
by M*I*B
2017-10-09 11:23
Forum: Feature requests
Topic: Aliases bind along to user, not floating free
Replies: 14
Views: 5267

Re: Aliases bind along to user, not floating free

... yapp, you're right. Open-source is great but sometimes things comes up that destroy a very good piece of software ... Maybe we are get lucky if someone in the future pick up that and it continues ... I'm quite good at hardware (development and layout-design (Altium)), but software is not my worl...
by M*I*B
2017-10-09 11:07
Forum: Feature requests
Topic: Aliases bind along to user, not floating free
Replies: 14
Views: 5267

Re: Aliases bind along to user, not floating free

ah, ok ... Why is there so less work on it? No more desire? Or other projects with more priority?
by M*I*B
2017-10-09 09:38
Forum: General discussions
Topic: Again and again: Database version could not be detected :(
Replies: 7
Views: 2610

Re: Again and again: Database version could not be detected :(

... hmmm ... Yes, the DB are on the same machine and only allow connection from localhost ... Last night I have got a new idea while a short sleepless phase. Let me try out this idea... that takes some days due my holiday is over and I have to work ... For this I have to create a 2nd DB-Engine and s...
by M*I*B
2017-10-09 09:34
Forum: Feature requests
Topic: Aliases bind along to user, not floating free
Replies: 14
Views: 5267

Re: Aliases bind along to user, not floating free

... uhhh! Democratic development? Cool :D

I do not think I can create such a poll with my bad English. I believe that my idea is clear due the whole thread... Maybe you or someone can create a poll?
by M*I*B
2017-10-08 19:08
Forum: Feature requests
Topic: Aliases bind along to user, not floating free
Replies: 14
Views: 5267

Re: Aliases bind along to user, not floating free

No, you cant add the tab with scripting but you can if you want to change the HMS code yourself and recompile it. ;-) :lol: :lol: :lol: :roll: You don't know what you say... Later I have a Virus but really not a running MX 8) Thanx for the code. That will help a while ... I'm hopefully that you som...
by M*I*B
2017-10-08 18:23
Forum: Feature requests
Topic: Aliases bind along to user, not floating free
Replies: 14
Views: 5267

Re: Aliases bind along to user, not floating free

... ok, scripting is not my world and I believe much other also can't scripting ...

But one Q: Can I generate a TAB "Aliases" in the user account with scripting (similar to the TAB "Names" in Domains) to fix my need?
by M*I*B
2017-10-08 17:12
Forum: Feature requests
Topic: Aliases bind along to user, not floating free
Replies: 14
Views: 5267

Re: Aliases bind along to user, not floating free

Nope, that's not the same... Can be that my English is to bad to explain what I ment... I try an other way: The existing function is like a Car and fully individual. You can start here and drive anywhere you like. What I mean is like a Train. You can only start here and only travel to a fixed point....
by M*I*B
2017-10-08 16:05
Forum: Feature requests
Topic: Aliases bind along to user, not floating free
Replies: 14
Views: 5267

Re: Aliases bind along to user, not floating free

Yes, that is ok and I understand it this way also. But from my point of view the actual named ALIASES have a better name like REDIRECTIONS or FORWARDER. I know ALIASES on most MX that a User can have some other "aliases" that strictly bind to the user (see i.e. KerioMX). What does it mean to have bo...
by M*I*B
2017-10-08 13:29
Forum: Feature requests
Topic: Aliases bind along to user, not floating free
Replies: 14
Views: 5267

Aliases bind along to user, not floating free

hello there, hope I'm right here... At the Moment an Alias for a user have to be created freely and isn't not really belong to a user (similar to domain- aliases). If you have to kill a user, the aliases for them messing around alone with no matching user, if you forget them to kill also. My Q is: W...
by M*I*B
2017-10-08 13:00
Forum: General discussions
Topic: Again and again: Database version could not be detected :(
Replies: 7
Views: 2610

Re: Again and again: Database version could not be detected :(

I am entirely of your opinion as to interchangeability. But it's not really more difficult to change the value of the table, isn't it?! In my eyes the problem isn't the interchangeability. The problem is that HMS sometimes can't find the value in the table; don't ask my why... I have no idea :roll: ...
by M*I*B
2017-10-08 10:13
Forum: General discussions
Topic: Again and again: Database version could not be detected :(
Replies: 7
Views: 2610

Re: Again and again: Database version could not be detected :(

EDIT say: What I don't understand is why the Developer create a table with a single field with a single static value except to store that into the ini or in a zero-byte file named like the value or what else ... If I read around the net I find many topics like this one that can be solved with that I...
by M*I*B
2017-10-08 09:33
Forum: General discussions
Topic: Again and again: Database version could not be detected :(
Replies: 7
Views: 2610

Re: Again and again: Database version could not be detected :(

... yes, this table is present and accessible with value "5601" in there (new created DB)... I have take a look inside the older Logfiles (former version). There are many entry's with the same problem. While the running operation you haven't notice that due it looks like t5hat the problem fix itself...
by M*I*B
2017-10-07 10:56
Forum: General discussions
Topic: Again and again: Database version could not be detected :(
Replies: 7
Views: 2610

Again and again: Database version could not be detected :(

Hello there, since a short time, maybe since the last 2 or 3 Versions I ever get the shown error again and again... hMail runs here since round about 5 years, 1st with original mySQL, since 1 year with MariaDB. The hMail- Database is quite big due my whole family and some friends use the server inte...