Search found 765 matches

by katip
2007-11-08 21:48
Forum: Off-topic discussions
Topic: Version 5, status update
Replies: 8
Views: 4937

Kaan1983 - The server core in hMailServer 5 will be in unicode (which means that it can handle turkish characters for example). I have not finalized testing of this support yet. For instance, I'm unsure how it will work in the user interface (which is obviously very important) Hi Martin, don't worr...
by katip
2007-10-23 18:27
Forum: Off-topic discussions
Topic: DNSReport
Replies: 13
Views: 7254

by katip
2007-09-26 04:52
Forum: General discussions
Topic: How do spammers get onto a mail server that isn't open relay
Replies: 9
Views: 3782

If someone figures out passwords for accounts on your server, they are considered to be local when they send email. If you don't want them to be able to send email, you need to disable "Local to external" in the Internet IP range. Martin, As I mentioned here some days ago, I'm still thinking that h...
by katip
2007-09-15 20:03
Forum: General discussions
Topic: How to decode auth text
Replies: 1
Views: 1017

How to decode auth text

I would like to know how to decode auth conversations in logfile, i.e. usernames and passwords. TIA

//edit: ok. i should google first and find a number of tools :oops:
by katip
2007-09-13 23:17
Forum: General discussions
Topic: Spamming although AUTH and IP Ranges
Replies: 9
Views: 2631

However, I was thinking that "Allow deliveries external to external" is sending an email like From : user1@nonlocaldomain1.com To : user2@nonlocaldomain2.com ONLY by auth. first with username and pssw. of an existing local account by checking "Require auth. for deliveries to remote accounts" in that...
by katip
2007-09-12 20:40
Forum: General discussions
Topic: Spamming although AUTH and IP Ranges
Replies: 9
Views: 2631

Thx Martin, all is clear now.
by katip
2007-09-12 20:35
Forum: General discussions
Topic: Spamming although AUTH and IP Ranges
Replies: 9
Views: 2631

^DooM^ wrote:Authenticated users are trusted.
confusing IMHO
by katip
2007-09-12 20:30
Forum: General discussions
Topic: Spamming although AUTH and IP Ranges
Replies: 9
Views: 2631

^DooM^ wrote:Well from that snipit it shows that the info account is being used to send the email as it is authenticated.

I suggest you change the password on that account from 123456 to something less guessable.
Hi Doom,
But why this if external to external is not allowed from inet?
by katip
2007-09-12 19:57
Forum: General discussions
Topic: Spamming although AUTH and IP Ranges
Replies: 9
Views: 2631

Spamming although AUTH and IP Ranges

Hi, 125.84.214.67 is none of our IP addresses. neither sender nor receiver addresses are local. * advanced-> Internet (0.0.0.0-255.255.255.255) has lowest priority. * "external to external" is not chacked in that range. how does it come that this is spammed via our server? TIA Katip "SMTPD" 3592 166...
by katip
2007-09-10 21:06
Forum: Archived feature requests
Topic: Alternate FROM address for SMTP envelope
Replies: 2
Views: 2487

One downside with this feature is that your users would not receive bounces of messages that cannot be delivered. All bounces would be sent to the same user (to the From address). Workaround would be to forward all bounced mails to hMail postmaster/admin... whatever account thru ISP email settings....
by katip
2007-09-10 19:31
Forum: Archived feature requests
Topic: Alternate FROM address for SMTP envelope
Replies: 2
Views: 2487

Alternate FROM address for SMTP envelope

Hi Martin, all, in Pegasus Mail there is an option for SMTP Server settings which puts an alternative FROM email address to the headers (as RETURN-PATH) than the one in the clients settings. A lot of ISP requires this in the format of "user@ISP.com" which causes to reject emails with a different FRO...
by katip
2007-06-29 20:00
Forum: General discussions
Topic: Yabb 2.1 and Hmail 4.4B270
Replies: 1
Views: 2113

Yabb 2.1 and Hmail 4.4B270

Hi, It seems that Yabb SMTP engine is not compatible (or the opposite ;)) with Hmail. Here the relevant log lines: "SMTPD" 2620 778 "2007-06-29 20:35:00.802" "127.0.0.1" "SENT: 220 xxx.com ESMTP" "SMTPD" 2620 778 "2007-06-29 20:35:00.812" "127.0.0.1" "RECEIVED: EHLO 127.0.0.1" "SMTPD" 2620 778 "2007...
by katip
2007-06-09 18:21
Forum: General discussions
Topic: clamav sosdg changed return code ?
Replies: 3
Views: 2536

Heeey, great to see you here bruns (if you're actually that from SOSDG ;))
by katip
2007-04-16 03:22
Forum: Development & alpha discussions
Topic: hMailServer 4.4 = stable?
Replies: 30
Views: 19671

Never seen something unusual in our prod. env. & at home.
Stable.
by katip
2007-03-30 10:02
Forum: General discussions
Topic: IMAP attachments
Replies: 2
Views: 1637

Hi Martin,

sorry but it came out that ASSP is guilty. CCHam fails to deliver messages properly. I have to ask ASSP team. Thanks anyway.
by katip
2007-03-29 21:31
Forum: General discussions
Topic: IMAP attachments
Replies: 2
Views: 1637

IMAP attachments

Hi, (Martin) b.4.3.1.253 W2KP-SP4 Attachments (jpg, pdf, xls, doc, whatever..) in IMAP folders are ending up with errors while trying to open them with relevant apps. Here some examples from 4 different emails: good: Content-Type: text/plain; charset=iso-8859-1 Content-Transfer-Encoding: 8bit can't ...
by katip
2007-03-23 21:01
Forum: General discussions
Topic: Can I install hMailServer in Windows XP SP2 Professional
Replies: 15
Views: 10309

There is a tool named XP-Antispy which provides (as a bonus) an option to increase the number of TCP connections on an XP (even up to unlimited). Freeware. Just google :)
by katip
2007-03-16 06:47
Forum: General discussions
Topic: ASSP CC Spam & hMail
Replies: 2
Views: 1459

Hi Martin,

I posted your reply to ASSP forum and developer himself suggested to use latest build (1.3.1.10). I did so and the problem is solved. So, it was an ASSP issue. Thanks a lot.
by katip
2007-03-15 17:33
Forum: General discussions
Topic: ASSP CC Spam & hMail
Replies: 2
Views: 1459

ASSP CC Spam & hMail

Hi, Below debug extract of a trasmission from ASSP to hMail: "SMTPD" 1332 414705 "2007-03-15 17:16:20.062" "127.0.0.1" "RECEIVED: HELO myHserver" "SMTPD" 1332 414705 "2007-03-15 17:16:20.062" "127.0.0.1" "SENT: 250 Hello." "SMTPD" 1332 414705 "2007-03-15 17:16:20.062" "127.0.0.1" "RECEIVED: MAIL FRO...
by katip
2007-03-06 21:03
Forum: General discussions
Topic: hMailServer as MX backup
Replies: 13
Views: 7437

raymond wrote:
dedisoft wrote:Does the backup mode work the same way as on my main server (using anti-virus option, anti-spam option, logs functionality, with virus and spam reject) ?

Yes.
Are you sure that greylisting is working too? I couldn't manage this.
by katip
2007-03-02 06:38
Forum: General discussions
Topic: issues with mx-backup and spam
Replies: 5
Views: 2313

This was also annoying me with our backup server. This is caused by non-existent from addresses of various spam. A workaround is a general rule like: If From equal mailer-daemon@backup.server.com AND Body contains "Your message did not reach some or all of the intended recipients" Delete email This ...
by katip
2007-02-25 06:05
Forum: User contributed hMailServer 4 scripts
Topic: Let Users create their own accounts (Upgraded for 4.3)
Replies: 178
Views: 211119

You can define the vars at the top of the script if you wish by doing something like $strName = ""; but this really just comes down to the lack of error checking in the script. As mentioned I did not write the script I just secured it up a bit. I turn notices off on my servers as they just annoy me...
by katip
2007-02-24 17:46
Forum: User contributed hMailServer 4 scripts
Topic: Let Users create their own accounts (Upgraded for 4.3)
Replies: 178
Views: 211119

They aren't error messages they are notices. Are you running PHP5? PHP 5.1.2 Yes, they are notices. I'm not a PHP expert but assume that it's reading script lines in their sequence. Those lines causing the notices are statements about not (yet) defined variables as code for the actual form - which ...
by katip
2007-02-24 17:31
Forum: User contributed hMailServer 4 scripts
Topic: Let Users create their own accounts (Upgraded for 4.3)
Replies: 178
Views: 211119

Does the script work? Are you including this script from another script or using it standalone? Have you entered anything into the boxes when you get these errors or are you just leaving them blank as there is no error checking in that script and would throw up warnings if the boxes were empty. Hi ...
by katip
2007-02-24 07:32
Forum: User contributed hMailServer 4 scripts
Topic: Let Users create their own accounts (Upgraded for 4.3)
Replies: 178
Views: 211119

It's woking, but...

Thanks for this handy script and sorry for asking same question once again: I've copied/saved above script as signup.php, made proper mods and fired it from mydomain.com/cgi-bin/signup.php Following errors are displayed on top of the page: Notice: Undefined index: name in C:\(blah...)\cgi-bin\signup...
by katip
2007-02-04 06:22
Forum: General discussions
Topic: Rules - Mail Loop
Replies: 5
Views: 2146

Hi,

...AND Recipient-List not contains alias@aliasdomain.com

should stop looping ;)
Note that "Forward" is not equal to "Move". It creates another message.
by katip
2007-01-16 22:51
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 6550

Thanks Martin. This works as it is. However if user sends mixed to local and external in To field (and even mixes something similar in CC) then you're lost in rules I think. edit// Hmm. If you omit "To Not Contains @localdomain.com", at least *any* outgoing mail > xys size should be blocked, local a...
by katip
2007-01-16 21:17
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 6550

Any clue from anybody to above question?
by katip
2007-01-13 08:09
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 6550

Ok then.
What is your suggestion for a rule(set) which deletes *outgoing* mails greater than xyz size and let the local sender notify? I'm a bit confused :) TIA
by katip
2007-01-11 06:14
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 6550

This rule: if from contains katip@katip.com and if messagesize > 100 send a reply delete email works perfect. However: if from contains @katip.com and if messagesize > 100 send a reply delete email Causes the reply to be deleted too as far as I can see in the logs, if I'm not mistaking: "SMTPD" 896 ...
by katip
2007-01-10 21:47
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 6550

Hi Martin,

exact address ok but "contains" doesn't work in any case. FYI.
by katip
2007-01-10 19:32
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 6550

Yes Martin, you're right. Now it seems to be ok. The problem was the "mail from" field defined in my mail client (Pegasus). Glad to hear that you noted this point though.

My sample filters were just do explain the problem. Of course, a "delete email" will be the last line there. Thank you.
by katip
2007-01-09 20:46
Forum: Development & alpha discussions
Topic: Signatures
Replies: 2
Views: 2544

Indeed, the problem should be mail client specific.
I've tested with TB now and sigs are ok.
But PegasusMail (with my previous tests) handles this somehow weird I think. I have to look into it's options. Thank you.
by katip
2007-01-09 20:15
Forum: Development & alpha discussions
Topic: Signatures
Replies: 2
Views: 2544

Signatures

Hi Martin,

4.4b254

1. Account and domain signatures don't seem to be appended.
2. Signatures containing special chars are deleted completely when trying to save them.

FYI. TIA
by katip
2007-01-08 20:15
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 6550

It's a global rule.
What I actually would like to do is to put a rule which deletes outgoing messages with a certain size or above and tells this to the sender.
by katip
2007-01-08 00:46
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 6550

Send reply by rules

"Send a reply" in rules (both global and account) don't work for local senders here (4.4b254). i.e. message is sent from local user: if from contains katip@katip.com and if messagesize > 100 send a reply Reply never arrives (not generated) to katip@katip.com (log extract below) "SMTPD" 800 31226 "20...
by katip
2007-01-04 20:28
Forum: User contributed hMailServer 4 scripts
Topic: Let Users create their own accounts (Upgraded for 4.3)
Replies: 178
Views: 211119

Errors

I saved the script as it is as "signup.php". When I call it following errors are displayed: Notice: Undefined index: name in C:\Jana2\html\katip\cgi-bin\WebMail\src\signup.php on line 21 Notice: Undefined index: user in C:\Jana2\html\katip\cgi-bin\WebMail\src\signup.php on line 22 Notice: Undefined ...
by katip
2007-01-04 20:20
Forum: Off-topic discussions
Topic: Pegasus and Mercury dead?
Replies: 3
Views: 3236

Pegasus and Mercury dead?

David Harris will no more develop his suite.

http://www.pmail.com/
by katip
2007-01-04 20:17
Forum: General discussions
Topic: PHPWebadmin modifications in language file don't apply
Replies: 5
Views: 3060

Also, I don't see how they could possibly be kept/cached until server restart. That's a normal PHP-script.
Yes, me too. Have you checked this? Just try to change something in your language.ini and F5 your browser.
by katip
2006-12-28 20:10
Forum: General discussions
Topic: PHPWebadmin modifications in language file don't apply
Replies: 5
Views: 3060

Martin,

it seems that your globals in hmailserver_string_constants.php are kept till another restart of the server. fyi..

//edit
server-box I mean.
by katip
2006-12-28 07:22
Forum: General discussions
Topic: PHPWebadmin modifications in language file don't apply
Replies: 5
Views: 3060

Yes, I'm editing \hMailServer\Languages\turkish.ini Here config.php $hmail_config['rootpath'] = "c:/Jana2/html/katip/cgi-bin/PHPWebAdmin/"; $hmail_config['rooturl'] = "http://www.katip.com/cgi-bin/PHPWebAdmin/"; $hmail_config['includepath'] = $hmail_config['rootpath'] . "include/"; $hmail_config['te...
by katip
2006-12-27 19:42
Forum: General discussions
Topic: PHPWebadmin modifications in language file don't apply
Replies: 5
Views: 3060

PHPWebadmin modifications in language file don't apply

Hi all,

I've made some mods in language.ini (turkish.ini) but they don't apply.
Cleared cache, restart service, no avail..
What to do? TIA
by katip
2006-12-24 19:32
Forum: General discussions
Topic: PHPwebadmin language
Replies: 6
Views: 4358

PHPWebadmin Language mods don't apply

Hi all,

I've made some mods in language.ini (turkish.ini) but they don't apply.
Cleared cache, restart service, no avail :(
What to do? TIA
by katip
2006-12-23 15:38
Forum: General discussions
Topic: How to disable authentication for LAN?
Replies: 4
Views: 2653

Thx

Indeed, thanks!
Hah! My mind obviously went to DNS MX priority which is the opposit :oops:
by katip
2006-12-23 09:32
Forum: General discussions
Topic: How to disable authentication for LAN?
Replies: 4
Views: 2653

How to disable authentication for LAN?

Hi all, I have defined 3 IP ranges: 127.0.0.1 - 127.0.0.1 - MyComputer - Priority 10 Allow connections & Allow deliveries from - All is checked except External to External. Require Authentication... none is checked 192.168.1.1 - 192.168.1.255 - LAN - Priority 20 Allow connections & Allow deliveries ...