hMailServer cannot send mail to self

Use this forum if you want to discuss a problem or ask a question related to a hMailServer beta release.
Post Reply
farwell
New user
New user
Posts: 3
Joined: 2015-04-13 15:22

hMailServer cannot send mail to self

Post by farwell » 2015-04-13 16:12

I have just installed hMailServer and I create serveral account. I found that account(test@example.cn) cannot send mail to self, but it can send mail to others including local address or external address. When an account send to self, my outlook or foxmail receive a error message: 550 User not found. But I am sure the accout exists.
I think I have setted IPRange correctly. I have checked all the checkbox.
I open the smtp log and part of the logs as below:

"SMTPD" 3800 1195 "2015-04-13 21:38:03.572" "101.95.1.102" "RECEIVED: ***"
"SMTPD" 3800 1195 "2015-04-13 21:38:03.578" "101.95.1.102" "SENT: 235 authenticated."
"SMTPD" 432 1195 "2015-04-13 21:38:03.755" "101.95.1.102" "RECEIVED: MAIL FROM: <test@example.cn> SIZE=1355"
"SMTPD" 432 1195 "2015-04-13 21:38:03.757" "101.95.1.102" "SENT: 250 OK"
"SMTPD" 3732 1195 "2015-04-13 21:38:03.924" "101.95.1.102" "RECEIVED: RCPT TO: <test@example.cn>"
"SMTPD" 3732 1195 "2015-04-13 21:38:03.925" "101.95.1.102" "SENT: 250 OK"
"SMTPD" 3800 1195 "2015-04-13 21:38:03.937" "101.95.1.102" "RECEIVED: "
"SMTPD" 3800 1195 "2015-04-13 21:38:03.938" "101.95.1.102" "SENT: 503 Bad sequence of commands"
"SMTPD" 3764 1195 "2015-04-13 21:38:03.938" "101.95.1.102" "RECEIVED: ."
"SMTPD" 3764 1195 "2015-04-13 21:38:03.938" "101.95.1.102" "SENT: 503 Bad sequence of commands"
"SMTPD" 3732 1195 "2015-04-13 21:38:03.939" "101.95.1.102" "RECEIVED: QUIT"
"SMTPD" 3732 1195 "2015-04-13 21:38:03.939" "101.95.1.102" "SENT: 221 goodbye"

Before this server in HongKong, I have installed hMailServer in another Server in Chinese. The Chinese one is running well. I have re-installed hMailServer Of HongKong serveral times.
Actually, this error occurs sometimes, 20% period of time its OK, and most of the time I receive the error message.

User avatar
jimimaseye
Moderator
Moderator
Posts: 8647
Joined: 2011-09-08 17:48

Re: hMailServer cannot send mail to self

Post by jimimaseye » 2015-04-13 19:08

farwell wrote: "SMTPD" 3800 1195 "2015-04-13 21:38:03.572" "101.95.1.102" "RECEIVED: ***"
"SMTPD" 3800 1195 "2015-04-13 21:38:03.578" "101.95.1.102" "SENT: 235 authenticated."
"SMTPD" 432 1195 "2015-04-13 21:38:03.755" "101.95.1.102" "RECEIVED: MAIL FROM: <test@example.cn> SIZE=1355"
"SMTPD" 432 1195 "2015-04-13 21:38:03.757" "101.95.1.102" "SENT: 250 OK"
"SMTPD" 3732 1195 "2015-04-13 21:38:03.924" "101.95.1.102" "RECEIVED: RCPT TO: <test@example.cn>"
"SMTPD" 3732 1195 "2015-04-13 21:38:03.925" "101.95.1.102" "SENT: 250 OK"
"SMTPD" 3800 1195 "2015-04-13 21:38:03.937" "101.95.1.102" "RECEIVED: "
"SMTPD" 3800 1195 "2015-04-13 21:38:03.938" "101.95.1.102" "SENT: 503 Bad sequence of commands"
"SMTPD" 3764 1195 "2015-04-13 21:38:03.938" "101.95.1.102" "RECEIVED: ."
"SMTPD" 3764 1195 "2015-04-13 21:38:03.938" "101.95.1.102" "SENT: 503 Bad sequence of commands"
"SMTPD" 3732 1195 "2015-04-13 21:38:03.939" "101.95.1.102" "RECEIVED: QUIT"
"SMTPD" 3732 1195 "2015-04-13 21:38:03.939" "101.95.1.102" "SENT: 221 goodbye"
The clue is in the log. It is receiving duff response from your client.

The problem is with your client.
5.7 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

farwell
New user
New user
Posts: 3
Joined: 2015-04-13 15:22

Re: hMailServer cannot send mail to self

Post by farwell » 2015-04-14 03:40

To fix the problem I have installed another client foxmail, Are both outlook and foxmail have problem? If my clients has a problem, why the server in chinese which I connect with using the same two clients work well.

User avatar
mattg
Moderator
Moderator
Posts: 20900
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: hMailServer cannot send mail to self

Post by mattg » 2015-04-14 08:56

It could be firewall, antivirus, or router taht is modifying the SMTP traffic.

It could also be the Great Firewall of China upsetting things, depending on where your server and mail clients are located.
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
jimimaseye
Moderator
Moderator
Posts: 8647
Joined: 2011-09-08 17:48

Re: hMailServer cannot send mail to self

Post by jimimaseye » 2015-04-14 09:59

farwell wrote:To fix the problem I have installed another client foxmail, Are both outlook and foxmail have problem? If my clients has a problem, why the server in chinese which I connect with using the same two clients work well.
#Dont know, but it isnt Hmailserver. Hmailserver is simply reporting what it received. As Matt says, it could be any of the things he mentioned: you need to go through and investigate each one. (We cannot help you with this).

However, to be sure, show us a screen shot of your IP RANGES.
5.7 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

farwell
New user
New user
Posts: 3
Joined: 2015-04-13 15:22

Re: hMailServer cannot send mail to self

Post by farwell » 2015-04-16 08:39

I found that if I used client in HongKong to connect to the hMailServer in HongKong, there is no problem. So I think this problem may be because of China great firewall. If that is true, whether I can fix problem by using SSL. Does client encrypt the sender and receiver mail addresses in SSL connection?

User avatar
mattg
Moderator
Moderator
Posts: 20900
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: hMailServer cannot send mail to self

Post by mattg » 2015-04-16 15:41

Yep SSL, and a non standard port should help.

The Chinese government seems to have some very smart people working for them though. You still may not beat them.
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

nitinkhubani
New user
New user
Posts: 1
Joined: 2017-02-09 07:14

Re: hMailServer cannot send mail to self

Post by nitinkhubani » 2017-02-09 07:17

Were you able to fix the issue? I am getting exact same error;

"SMTPD" 472 8 "2017-02-09 13:11:27.484" "168.63.136.126" "RECEIVED: MAIL FROM: <user@gt.com>"
"SMTPD" 472 8 "2017-02-09 13:11:27.493" "168.63.136.126" "SENT: 250 OK"
"SMTPD" 7604 8 "2017-02-09 13:11:27.541" "168.63.136.126" "RECEIVED: RCPT TO: <user@gt.com>"
"SMTPD" 7604 8 "2017-02-09 13:11:27.553" "168.63.136.126" "SENT: 250 OK"
"SMTPD" 7604 8 "2017-02-09 13:11:27.557" "168.63.136.126" "RECEIVED: "
"SMTPD" 7604 8 "2017-02-09 13:11:27.561" "168.63.136.126" "SENT: 503 Bad sequence of commands"
"SMTPD" 7604 8 "2017-02-09 13:11:27.566" "168.63.136.126" "RECEIVED: ."
"SMTPD" 7604 8 "2017-02-09 13:11:27.571" "168.63.136.126" "SENT: 503 Bad sequence of commands"
"SMTPD" 7604 8 "2017-02-09 13:11:27.576" "168.63.136.126" "RECEIVED: QUIT"
"DEBUG" 7604 "2017-02-09 13:11:27.581" "Deleting message file."
"SMTPD" 7604 8 "2017-02-09 13:11:27.585" "168.63.136.126" "SENT: 221 goodbye"

The server is in China and client outside china...

User avatar
mattg
Moderator
Moderator
Posts: 20900
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: hMailServer cannot send mail to self

Post by mattg » 2017-02-09 08:01

Did you try SSL connections on a non standard port?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

mzv
New user
New user
Posts: 4
Joined: 2019-09-17 13:03

Re: hMailServer cannot send mail to self

Post by mzv » 2019-09-17 13:23

I have the same case - hMailServer randomly receives DOT.

Issue 1

Code: Select all

"SMTPD" 1716    31      "2019-09-13 23:35:42.700"       "127.0.0.1"     "RECEIVED: RCPT TO:<zzzzzz@gmail.com>"
"SMTPD" 1716    31      "2019-09-13 23:35:42.700"       "127.0.0.1"     "SENT: 250 OK"
"SMTPD" 1428    31      "2019-09-13 23:35:42.700"       "127.0.0.1"     "RECEIVED: DATA"
"SMTPD" 1428    31      "2019-09-13 23:35:42.716"       "127.0.0.1"     "SENT: 354 OK, send."
"DEBUG" 1416    "2019-09-13 23:35:42.716"       "Adding task AsynchronousTask to work queue Asynchronous task queue"
"DEBUG" 1944    "2019-09-13 23:35:42.716"       "Executing task AsynchronousTask in work queue Asynchronous task queue"
"DEBUG" 1944    "2019-09-13 23:35:42.716"       "Saving message: {F1C2FDC2-312E-4AF4-84AB-107C3B9602E7}.eml"
"DEBUG" 1944    "2019-09-13 23:35:42.716"       "Requesting SMTPDeliveryManager to start message delivery"
"SMTPD" 1944    31      "2019-09-13 23:35:42.716"       "127.0.0.1"     "SENT: 250 Queued (0.000 seconds)"
"DEBUG" 2044    "2019-09-13 23:35:42.716"       "Adding task DeliveryTask to work queue SMTP delivery queue"
"DEBUG" 1260    "2019-09-13 23:35:42.731"       "Executing task DeliveryTask in work queue SMTP delivery queue"
"DEBUG" 1260    "2019-09-13 23:35:42.731"       "Delivering message..."
"DEBUG" 1260    "2019-09-13 23:35:42.731"       "Applying rules"
"DEBUG" 1260    "2019-09-13 23:35:42.731"       "Executing event OnMessageDeliver"
"SMTPD" 1612    31      "2019-09-13 23:35:42.731"       "127.0.0.1"     "RECEIVED: ."
"SMTPD" 1612    31      "2019-09-13 23:35:42.731"       "127.0.0.1"     "SENT: 503 Bad sequence of commands"
"DEBUG" 1260    "2019-09-13 23:35:42.747"       "Event completed"
Configuration:
IIS 6.0 relays to hMailServer on the same server.
hMailServer port 1025, STARTTLS (Required)
Both IIS and hMailServer use the same Let'sEncrypt certificate.

Issue - randomly, ~1 email per hour is dropped.

Reason (most likely, never happened before) - extra CPU was added to server.

Workaround - disable encryption.

Issue 2 - very similar.
Same configuration works ok and stable, until at some moment hMailServer stops receiving emails with

Code: Select all

Message: short read
After this no emails are received, but queued at IIS.

Workaround - restart hMailServer or disable encryption.

User avatar
mattg
Moderator
Moderator
Posts: 20900
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: hMailServer cannot send mail to self

Post by mattg » 2019-09-17 23:34

What version of hMailserver?

You really should start your own thread and link back to this one if you think it relevant please
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

mzv
New user
New user
Posts: 4
Joined: 2019-09-17 13:03

Re: hMailServer cannot send mail to self

Post by mzv » 2019-09-18 08:40

hMailServer version is the latest stable 5.6.7 - Build 2425.

I've created a new topic
https://www.hmailserver.com/forum/viewt ... =7&t=34371

Post Reply