Cannot recieve emails

This section contains user-submitted tutorials.
Post Reply
GeobhMail
New user
New user
Posts: 5
Joined: 2018-07-04 11:00

Cannot recieve emails

Post by GeobhMail » 2018-07-04 12:05

The response was:
The recipient server did not accept our requests to connect. Learn more at https://support.google.com/mail/answer/7720 [mail.cladda.xyz. 154.70.1.16: timed out]

My hMailServer is behind a router, i have done port forwarding for 25/587/465/995/993/110/143 ports.

I have also set up SSL using openSSL.

I can connect to my server on all the ports from cmd on all the ports using

Code: Select all

openssl s_client -connect mail.cladda.xyz:25
mxToolbox SMTP Test returns:
Connecting to 154.70.1.16
7/4/2018 5:00:29 AM Connection attempt #1 - Unable to connect after 15 seconds. [15.00 sec]

LookupServerv2 15001ms

Where do i dig

Regards
Geob

User avatar
jimimaseye
Moderator
Moderator
Posts: 8579
Joined: 2011-09-08 17:48

Re: Cannot recieve emails

Post by jimimaseye » 2018-07-04 13:04

Do telnet tests to your address on port 25 from:

a, a WAN side machine
b, a LAN side machine, not the server, to LAN address of the server.

If they connect, then enable SMTP and APPLICATION logging, try to send in another email and then view the results of the log (post them here). Also run this and post the results: viewtopic.php?f=20&t=30914
5.7 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

GeobhMail
New user
New user
Posts: 5
Joined: 2018-07-04 11:00

Re: Cannot recieve emails

Post by GeobhMail » 2018-07-04 16:36

telnet tests only return 220 mail.cladda.xyz ESMTP with None/STARTTLS(Optiona)/STARTTLS(Required) Connection security types.

Dead with SSL/TLS Connection security chosen.

User avatar
jimimaseye
Moderator
Moderator
Posts: 8579
Joined: 2011-09-08 17:48

Re: Cannot recieve emails

Post by jimimaseye » 2018-07-04 16:41

jimimaseye wrote:
2018-07-04 13:04
If they connect, then enable SMTP and APPLICATION logging, try to send in another email and then view the results of the log (post them here). Also run this and post the results: viewtopic.php?f=20&t=30914
5.7 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

GeobhMail
New user
New user
Posts: 5
Joined: 2018-07-04 11:00

Re: Cannot recieve emails

Post by GeobhMail » 2018-07-04 16:44

Code: Select all

"SMTPD"	13340	146	"2018-07-04 17:34:10.996"	"154.70.1.16"	"SENT: 220 mail.cladda.xyz ESMTP"
"SMTPD"	16524	146	"2018-07-04 17:37:41.259"	"154.70.1.16"	"RECEIVED: ehlo mail.cladda.xyz"
"SMTPD"	16524	146	"2018-07-04 17:37:41.259"	"154.70.1.16"	"SENT: 250-mail.cladda.xyz[nl]250-SIZE 20480000[nl]250-AUTH LOGIN[nl]250 HELP"
"SMTPD"	16524	146	"2018-07-04 17:38:04.732"	"154.70.1.16"	"RECEIVED: mail from:georgeobera@gmail.com"
"SMTPD"	16524	146	"2018-07-04 17:38:04.732"	"154.70.1.16"	"SENT: 250 OK"
"SMTPD"	16524	146	"2018-07-04 17:38:37.673"	"154.70.1.16"	"RECEIVED: rcpt to:support@cladda.xyz"
"SMTPD"	16524	146	"2018-07-04 17:38:37.675"	"154.70.1.16"	"SENT: 250 OK"
"SMTPD"	16524	146	"2018-07-04 17:39:39.112"	"154.70.1.16"	"RECEIVED: data"
"SMTPD"	16524	146	"2018-07-04 17:39:39.113"	"154.70.1.16"	"SENT: 354 OK, send."
"SMTPD"	5964	146	"2018-07-04 17:40:35.619"	"154.70.1.16"	"SENT: 250 Queued (56.500 seconds)"
"APPLICATION"	11016	"2018-07-04 17:40:35.622"	"SMTPDeliverer - Message 92: Delivering message from georgeobera@gmail.com to support@cladda.xyz. File: M:\Programs\hMailServer\Data\{ED30DAED-1524-4F89-9BF4-D32A49165E0A}.eml"
"APPLICATION"	11016	"2018-07-04 17:40:35.672"	"SMTPDeliverer - Message 92: Message delivery thread completed."

GeobhMail
New user
New user
Posts: 5
Joined: 2018-07-04 11:00

Re: Cannot recieve emails

Post by GeobhMail » 2018-07-04 16:47

Delivers a blank message though, no Subject, no From, no Email body

User avatar
jimimaseye
Moderator
Moderator
Posts: 8579
Joined: 2011-09-08 17:48

Re: Cannot recieve emails

Post by jimimaseye » 2018-07-04 18:03

jimimaseye wrote:
2018-07-04 13:04
Also run this and post the results: viewtopic.php?f=20&t=30914
And

Isnt the problem that you cannot send OUT emails?

If so, send a test email out (FROM hmailserver) - wait 90 seconds, and post the results.
5.7 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

GeobhMail
New user
New user
Posts: 5
Joined: 2018-07-04 11:00

Re: Cannot recieve emails

Post by GeobhMail » 2018-07-04 18:57

Sending is fine, i can send to both internal and external accounts, but cannot receive from external accounts.
Internal to Internal accounts is received with SSL/TLS Connection security type. HMS does not support STARTTLS it says.

User avatar
mattg
Moderator
Moderator
Posts: 20837
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Cannot recieve emails

Post by mattg » 2018-07-05 00:49

Do you have a certificate installed??
GeobhMail wrote:
2018-07-04 12:05
I have also set up SSL using openSSL.
Could mean that you have a self signed certificate, but it may just mean that you've installed OpenSSL. I can't tell.


For the forth time
jimimaseye wrote:
2018-07-04 13:04
Also run this and post the results: viewtopic.php?f=20&t=30914
If you did that when first asked we would have more of an idea of what is wrong.

It could be cert related, or port security, or protocol or cipher or....
Help us to help you please.

The diagnostics requested are de-identified, and you can vet them before you post them.
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

Post Reply