Libmysql.dll 6.1.11.0 (32/64-Bit) is incompatible with hMailServer 5.6.x

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
User avatar
Dravion
Senior user
Senior user
Posts: 1688
Joined: 2015-09-26 11:50
Location: Germany
Contact:

Libmysql.dll 6.1.11.0 (32/64-Bit) is incompatible with hMailServer 5.6.x

Post by Dravion » 2018-12-11 00:07

At testing my own hMailServer builds, i stumbled over this issue.

In short:
The official libmysql.dll (version: 6.1.11) from the archive (mysql-connector-c-6.1.11-win32.zip) shipped as default
by Oracle doesnt work with hMailServer 5.6.x 32-Bit and 64-Bit!

The latest working version is -> 5.7.24.0

For 32-Bit hMailServer 5.6.x and higher, download this version:
https://dev.mysql.com/get/Downloads/MyS ... -win32.zip

For 64-Bit hMailServer 5.6.x and higher, download this version:
https://dev.mysql.com/get/Downloads/MyS ... winx64.zip

Screenshots of the Error:
libmysql_error_6.1.11.0.png
If you replace the version 6.1.11.0 with 5.7.24, it works

Success:
libmysql_success_5.7.24.0.png

Post Reply