No subject No attachment after receive or send +1 MB

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
acetin
New user
New user
Posts: 4
Joined: 2020-07-20 08:24

No subject No attachment after receive or send +1 MB

Post by acetin » 2020-07-20 10:02

Hi,

We have very strange problem we have never did until now.When we send or receive mail more than +1MB mail not contain Subcject,body and attachment, just an empty mail.in detail section just tree line.
Detail section
Return-Path: ma@m***s.com.tr
From: ma@m****s.com.tr
Date: Mon, 20 Jul 2020 10:11:01 +0300


Sample log

Code: Select all

"DEBUG"	4484	"2020-07-20 10:10:58.428"	"TCP connection started for session 611543"
"SMTPD"	4484	611543	"2020-07-20 10:10:58.428"	"213.194.116.*"	"SENT: 220 me*****.com"
"SMTPD"	4440	611543	"2020-07-20 10:10:58.428"	"213.194.116.*"	"RECEIVED: EHLO smtp.****.com.tr"
"SMTPD"	4440	611543	"2020-07-20 10:10:58.428"	"213.194.116.*"	"SENT: 250-meram-ue.com[nl]250-SIZE 120000000[nl]250-AUTH LOGIN[nl]250 HELP"
"SMTPD"	4464	611543	"2020-07-20 10:10:58.443"	"213.194.116.*"	"RECEIVED: MAIL FROM:<ma@****.com.tr> SIZE=5235974"
"SMTPD"	4464	611543	"2020-07-20 10:10:58.443"	"213.194.116.*"	"SENT: 250 OK"
"SMTPD"	4484	611543	"2020-07-20 10:10:58.443"	"213.194.116.*"	"RECEIVED: RCPT TO:<si****@****.com>"
"SMTPD"	4484	611543	"2020-07-20 10:10:58.443"	"213.194.116.*"	"SENT: 250 OK"
"SMTPD"	4432	611522	"2020-07-20 10:10:58.521"	"185.143.73.*"	"RECEIVED: QUIT"
"SMTPD"	4432	611522	"2020-07-20 10:10:58.521"	"185.143.73.*"	"SENT: 221 goodbye"
"DEBUG"	4448	"2020-07-20 10:10:58.521"	"Ending session 611522"
"SMTPD"	4432	611543	"2020-07-20 10:10:58.537"	"213.194.116.*"	"RECEIVED: DATA"
"SMTPD"	4432	611543	"2020-07-20 10:10:58.537"	"213.194.116.*"	"SENT: 354 OK, send."
And This error just spamming log file may be not relevant

Code: Select all

ERROR"	4464	"2020-07-20 10:10:59.115"	"Severity: 2 (High), Code: HM4208, Source: File::ReadFile(), Description: An error occured when reading file., Message: bad allocation"
"ERROR"	4464	"2020-07-20 10:10:59.115"	"Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR"	4464	"2020-07-20 10:10:59.115"	"Severity: 3 (Medium), Code: HM5042, Source: File::ReadTextFile, Description: An unknown error occurred while reading a text file from disk."
"ERROR"	4464	"2020-07-20 10:10:59.115"	"Severity: 1 (Critical), Code: HM5062, Source: IMAPFetch::ReportCriticalError_, Description: ERROR HM10001 - IMAP FETCH: Error when loading MIME message. - C:\Program Files (x86)\Server\Data\m****.com\info.***\F9\{F9B63365-413D-4BAF-B87F-48589932F539}.eml"
"ERROR"	4464	"2020-07-20 10:10:59.115"	"Severity: 3 (Medium), Code: HM5136, Source: TCPConnection::AsyncReadCompleted, Description: An error occured while parsing data. Data length: 46, Data: 7 UID fetch 1486 (UID RFC822.SIZE BODY.PEEK[]). Remote IP: 81.215.208.83"

User avatar
katip
Senior user
Senior user
Posts: 766
Joined: 2006-12-22 07:58
Location: Istanbul

Re: No subject No attachment after receive or send +1 MB

Post by katip » 2020-07-20 10:49

any AV running with HMS data folder not excluded?
Katip
--
HMS 5.7.0 x64, MariaDB 10.4.10 x64, SA 3.4.2, ClamAV 0.101.2 + SaneS

acetin
New user
New user
Posts: 4
Joined: 2020-07-20 08:24

Re: No subject No attachment after receive or send +1 MB

Post by acetin » 2020-07-20 12:53

katip wrote:
2020-07-20 10:49
any AV running with HMS data folder not excluded?
Exculuded data folder from AV and also looked up to scan log and no delete action on it.

acetin
New user
New user
Posts: 4
Joined: 2020-07-20 08:24

Re: No subject No attachment after receive or send +1 MB

Post by acetin » 2020-07-20 13:30

I found those mails on \Logs\Problematic messages strange. Why?

User avatar
mattg
Moderator
Moderator
Posts: 20960
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: No subject No attachment after receive or send +1 MB

Post by mattg » 2020-07-20 14:18

That's where hMailserver puts messages it can't handle

acetin wrote:
2020-07-20 10:02
mail not contain Subcject,body and attachment, just an empty mail
I suspect that is related
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

acetin
New user
New user
Posts: 4
Joined: 2020-07-20 08:24

Re: No subject No attachment after receive or send +1 MB

Post by acetin » 2020-07-20 16:24

OK Problem solved. It's Cache problem. Disable cache in Hmail admin panel. Now its OK.

Post Reply