Remote control error 80070005

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
User avatar
naxaH
New user
New user
Posts: 29
Joined: 2010-11-15 14:33

Remote control error 80070005

Post by naxaH » 2010-11-15 14:45

Initially all worked. I don't remember that has occurred, but at remote connection to the server the error (look a picture in an investment) jumps out. The server works and on it it is possible to come into the administrative console. At a forum has found some decisions on adjustment DCOM - has adjusted. As a result without results. There are ideas?

Thanks for earlier!
Attachments
error.jpg
Server 2008R2/8GB/HM v.5.4 - 1944 SQL.

User avatar
mattg
Moderator
Moderator
Posts: 20232
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Remote control error 80070005

Post by mattg » 2010-11-15 15:52

Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
naxaH
New user
New user
Posts: 29
Joined: 2010-11-15 14:33

Re: Remote control error 80070005

Post by naxaH » 2010-11-16 08:51

I read it. Thanks. But there it is written about a server web. At me remote connection through the console. But I have all the same adjusted as there is written also an error repeats. What do I do not so? Thanks.
Server 2008R2/8GB/HM v.5.4 - 1944 SQL.

User avatar
mattg
Moderator
Moderator
Posts: 20232
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Remote control error 80070005

Post by mattg » 2010-11-16 09:10

Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
naxaH
New user
New user
Posts: 29
Joined: 2010-11-15 14:33

Re: Remote control error 80070005

Post by naxaH » 2010-11-16 09:48

mattg

Not work .( i uninstalled hmailserver admin and installed again, but there is no resultat .( Maybe delete smthing manual? CLSID or something in somewhere system reester (regedit)?
Server 2008R2/8GB/HM v.5.4 - 1944 SQL.

User avatar
mattg
Moderator
Moderator
Posts: 20232
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Remote control error 80070005

Post by mattg » 2010-11-16 09:58

http://www.hmailserver.com/documentatio ... hmailadmin
http://www.hmailserver.com/documentatio ... management

I've never persisted enough to get it to work myself. I use RDP to remotely access the server, and then administer the hMailserver
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
naxaH
New user
New user
Posts: 29
Joined: 2010-11-15 14:33

Re: Remote control error 80070005

Post by naxaH » 2010-11-16 10:26

ok. Maybe later the fix will creating. Will use RDP. Thx!
Server 2008R2/8GB/HM v.5.4 - 1944 SQL.

User avatar
naxaH
New user
New user
Posts: 29
Joined: 2010-11-15 14:33

Re: Remote control error 80070005

Post by naxaH » 2012-08-01 14:12

On the problem PC

the following registry entries have the value Y
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole\EnableDCOM
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole\EnableRemoteConnect

this is help me .)
Server 2008R2/8GB/HM v.5.4 - 1944 SQL.

fkuchta
New user
New user
Posts: 9
Joined: 2012-03-26 17:06

Re: Remote control error 80070005

Post by fkuchta » 2014-07-07 12:13

Old topic, but after looking for informations on the web, here is all that I've done and it works !

Sorry for the quick translation from french (I wrote my own doc to remember how to do)

************ ON SERVER
* Firewall port 135 for all protocols
* start DCOMCNFG
Network Components -> Component services -> Computers -> Poste de travail
right click Poste de travail -> Properties
Tab "COM Security"
Modify (2 buttons) : Add "network service" and yourself and/or your group (domain).
Also, take a look in Network Components -> Component services -> Computers -> Poste de travail -> DCOM Configuration -> hmailServer -> Properties
May be u'll have to change some values in security tab (tiking "default" ?).

************ ON WORKSTATION - EXTRACT FROM http://www.hmailserver.com/documentatio ... ter_remote
You need to have hMailServer Administrator installed, and the hMailServer COM library must be registered. Since there is no installation that does only this, you have to install a full hMailServer installation and then disable the hMailServer service. To install hMailServer, follow these steps:
Install the same version of hMailServer as on Computer A.
Open up the Control Panel, Administrative tools, Services.
Locate the hMailServer service, stop it and disable it.
Next, you need to tell Windows that when you're running hMailServer Administrator, you want to administer the hMailServer installation running on Computer A. This is done by modifying the settings for the hMailServer COM object on Computer B.
Open the Control panel, Administrative tools, Component services.
Expand Component services->Computers->My computer->DCOM config.
Locate the hMailServer
Right-click on it, and select Properties
On the Location-tab, de-select Run application on this computer and select "Run application on the following computer
Specify the name of Computer A
Start hMailAdmin.
hMailAdmin on Computer B should now administer hMailServer on Computer A.


Hope this helps!

Fabrice, Toulouse

fireball8931
New user
New user
Posts: 1
Joined: 2016-11-04 19:48

Re: Remote control error 80070005

Post by fireball8931 » 2016-11-04 19:54

I hate to resurrect an old thread, but the both of the 2 posts before mine were required to fix the issue.
I also found that you need to specify the DNS name of the server when connecting via the hMail admin application on the Workstation.
I was trying to use the IP address, and that was not working. As soon as I specified the actual Name of the server, boom, connected.

fkuchta wrote:Old topic, but after looking for informations on the web, here is all that I've done and it works !

Sorry for the quick translation from french (I wrote my own doc to remember how to do)

************ ON SERVER
* Firewall port 135 for all protocols
* start DCOMCNFG
Network Components -> Component services -> Computers -> Poste de travail (Computer)
right click Poste de travail (Computer) -> Properties
Tab "COM Security"
Modify (2 buttons) : Add "network service" and yourself and/or your group (domain).
Also, take a look in Network Components -> Component services -> Computers -> Poste de travail -> DCOM Configuration -> hmailServer -> Properties
May be u'll have to change some values in security tab (tiking "default" ?).

************ ON WORKSTATION - EXTRACT FROM http://www.hmailserver.com/documentatio ... ter_remote
You need to have hMailServer Administrator installed, and the hMailServer COM library must be registered. Since there is no installation that does only this, you have to install a full hMailServer installation and then disable the hMailServer service. To install hMailServer, follow these steps:
Install the same version of hMailServer as on Computer A.
Open up the Control Panel, Administrative tools, Services.
Locate the hMailServer service, stop it and disable it.
Next, you need to tell Windows that when you're running hMailServer Administrator, you want to administer the hMailServer installation running on Computer A. This is done by modifying the settings for the hMailServer COM object on Computer B.
Open the Control panel, Administrative tools, Component services.
Expand Component services->Computers->My computer->DCOM config.
Locate the hMailServer
Right-click on it, and select Properties
On the Location-tab, de-select Run application on this computer and select "Run application on the following computer
Specify the name of Computer A
Start hMailAdmin.
hMailAdmin on Computer B should now administer hMailServer on Computer A.


Hope this helps!

Fabrice, Toulouse

and
naxaH wrote:On the problem PC

the following registry entries have the value Y
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole\EnableDCOM
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole\EnableRemoteConnect

this is help me .)

User avatar
Dravion
Senior user
Senior user
Posts: 1471
Joined: 2015-09-26 11:50
Location: Germany
Contact:

Re: Remote control error 80070005

Post by Dravion » 2016-11-05 15:25

Try my Howto:
Howto: hMailAdmin -> DCOM Remote access
viewtopic.php?f=21&t=30392

Post Reply